股票配資平台資訊網-侃股網

 
 立即注冊

2019-7-9 10:24| 發布者: admin| 查看: 72| 評論: 0

摘要: 提取頭天的信號確定,不存在漂移,如果以當天的信號,存在不確定性,所以建議拿頭天的信號做參考。下面的代碼你可以加入你的選股公式里面作為一個過濾的條件,也可以作為單獨的選股公式,如果想作為一個選股公式最後 ...

前,我要求多空量能或者主力量能指標顯示為紅色(主力在入場的意思),下面提供給大家參考。

頭天多空量能或者主力量能紅色,第天就是漲的可能性大。頭天多空量能或者主力量能非紅色,第天就是跌的可能性大。
{資金動能-副圖}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趨勢:=(MA((C-HY1)*28,2))*0.1;
操盤4:STICKLINE(多空趨勢>=0 AND 多空趨勢>=REF(多空趨勢,1),24,24+多空趨勢,1.5,0),COLORRED;
減倉4:STICKLINE(多空趨勢>=0 AND 多空趨勢< REF(多空趨勢,1),24,24+多空趨勢,1.5,0), COLORYELLOW;
反彈4:STICKLINE(多空趨勢<0 AND 多空趨勢>=REF(多空趨勢,1),24,22+多空趨勢,1.5,0),COLORBLUE;
尋底4:STICKLINE(多空趨勢<0 AND 多空趨勢< REF(多空趨勢,1),24,24+多空趨勢,1.5,0),COLORGREEN; 
DRAWTEXT(ISLASTBAR=1,IF(多空趨勢>=0,22,22.3),'  多空'),COLORWHITE;
換手:=V*100/CAPITAL;
主力:=MA(換手,4);
大戶:=MA(換手,9);
中戶:=MA(換手,17);
散戶:=MA(換手,34);
均量:=(主力+大戶+中戶+散戶)/4;
成交量:V,COLORWHITE,NODRAW;
主力能量:(主力-均量)COLORMAGENTA,NODRAW;
大戶能量:(大戶-均量)COLORYELLOW,NODRAW;
中戶能量:(中戶-均量)COLORLIBLUE,NODRAW;
散戶能量:(散戶-均量)COLORBLUE,NODRAW;
操盤:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORRED;
減倉:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORYELLOW;
反彈:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORBLUE;
尋底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,14.4,14.6),'  機構'),COLORMAGENTA;
操盤1:STICKLINE(大戶能量>=0 AND 大戶能量>=REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORRED;
減倉1:STICKLINE(大戶能量>=0 AND 大戶能量< REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORYELLOW;
反彈1:STICKLINE(大戶能量<0 AND 大戶能量>=REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORBLUE;
尋底1:STICKLINE(大戶能量<0 AND 大戶能量< REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(大戶能量>=0,9.6,9.8),'  大戶'),COLORYELLOW;
JZ:=V/(ABS(主力能量)+ABS(大戶能量)+ABS(中戶能量)+ABS(散戶能量));{4,9,17,34日換手偏離值均分成交量}
ZLCJ:=JZ*ABS(主力能量);{4日換手偏離均量值換算當日成交量}
DHCJ:=JZ*ABS(大戶能量);{9日換手偏離均量值換算當日成交量}
ZHCJ:=JZ*ABS(中戶能量);{17日換手偏離均量值換算當日成交量}
SHCJ:=JZ*ABS(散戶能量);{34日換手偏離均量值換算當日成交量};
換手率:VOL/CAPITAL*100,LINETHICK0;
機構量:=ZLCJ,COLORMAGENTA,NODRAW;
大戶量:=DHCJ,COLORYELLOW,NODRAW;
中戶量:=ZHCJ,COLORLIBLUE,NODRAW;
散戶量:=SHCJ,COLORBLUE,NODRAW;
{完}
附︰如何提取其中的信息?下面代碼是提取頭天多空指標或機構指標顯示為紅色的代碼。
提取頭天的信號確定,不存在漂移,如果以當天的信號,存在不確定性,所以建議拿頭天的信號做參考。
下面的代碼你可以加入你的選股公式里面作為一個過濾的條件,也可以作為單獨的選股公式,如果想作為一個選股公式最後一句這麼寫就行了。
ZJDN:多空量能 OR 主力量能;{不要加等號,意思就是輸出結果的意思}
{頭天資金動能多空指標或機構指標二者之一顯示為紅色的代碼}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趨勢:=(MA((C-HY1)*28,2))*0.1;
多空量能:=REF(多空趨勢,1)>=0 AND REF(多空趨勢,1)>=REF(多空趨勢,2);
換手:=V*100/CAPITAL;
主力:=MA(換手,4);
大戶:=MA(換手,9);
中戶:=MA(換手,17);
散戶:=MA(換手,34);
均量:=(主力+大戶+中戶+散戶)/4;
主力能量:=主力-均量;
主力量能:=REF(主力能量,1)>=0 AND REF(主力能量,1)>=REF(主力能量,2);
ZJDN:=多空量能 OR 主力量能;
{OR就是多空量能和主力量能至少一個指標顯示紅色的意思,如果用AND連接就是要求兩者同時為紅的意思}
{頭天資金動能指標里面︰多空指標或機構指標二者之一顯示為紅色的選股公式}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趨勢:=(MA((C-HY1)*28,2))*0.1;
多空量能:=REF(多空趨勢,1)>=0 AND REF(多空趨勢,1)>=REF(多空趨勢,2);
換手:=V*100/CAPITAL;
主力:=MA(換手,4);
大戶:=MA(換手,9);
中戶:=MA(換手,17);
散戶:=MA(換手,34);
均量:=(主力+大戶+中戶+散戶)/4;
主力能量:=主力-均量;
主力量能:=REF(主力能量,1)>=0 AND REF(主力能量,1)>=REF(主力能量,2);
ZJDN:多空量能 OR 主力量能;

{當天資金動能指標里面︰多空指標或機構指標二者之一顯示為紅色的選股公式}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趨勢:=(MA((C-HY1)*28,2))*0.1;
多空量能:=多空趨勢>=0 AND 多空趨勢>=REF(多空趨勢,1);
換手:=V*100/CAPITAL;
主力:=MA(換手,4);
大戶:=MA(換手,9);
中戶:=MA(換手,17);
散戶:=MA(換手,34);
均量:=(主力+大戶+中戶+散戶)/4;
主力能量:=主力-均量;
主力量能:=主力能量>=0 AND 主力能量>=REF(主力能量,1);
ZJDN:多空量能 OR 主力量能;

返回頂部